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STECA  User Manual 
 

1. SETUP OR INSTALLATION OF THE SOFTWARE 
 

a. Double click the setup.exe file. STECA Setup screen showing “Welcome to the STECA 

installation program” (Figure 1) message appears.  

 
Figure 1.  Setup Screen 1 

b. Click the OK button. Figure 2 shows up. 

 

c. Click the Change Directory button. 

 

 



 3

 
Figure 2. Setup Screen 2 

d. The screen shown in Figure 3 will appear. Chose the desired drive where the software is 

to be installed. In the path: box, type STECA after the drive name, as shown in Figure 3. 

Then click the OK button. Figure 4 appears. Follow the screen instructions. 

 
Figure 3. Change Directory Screen 
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Figure 4. Setup Screen 4  

e. Click the Continue button on the screen as shown in Figure 5.  This will take a few 

minutes for the computer to copy the files and to install the STECA software into the 

specified drive. 

 
Figure 5. Setup Screen 5 

f. After the completion of installation the user will get a message indicating so. Just click 

OK to finish. 
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g. To open the software for use, click the Start button at the lower left corner of the 

desktop. In the Programs menu, select the STECA submenu. Select the Steca icon in the 

submenu that appears. The option screen will then load. 

 

2. DESCRIPTION OF THE SOFTWARE 

 
This software has a very self-explanatory graphical user interface (GUI) for input of data and a 

step-by-step analysis.  The screen that appears first is the option screen.  Here the user must give 

a computation option.  The next screen that comes up is based on what type of analysis and what 

station option one wishes to select. The analysis options are: Degree Day, Basic Statistics, Data 

Preparation, Frequency Analysis, Atmospheric Climate Analysis, Heat Index, Wind Chill 

and Relative Humidity.  The station option has only two choices: Single Station and Multiple 

Station.  

 

Any analysis begins with the selection of an input data file from the File menu. In the main 

menu, there is a File menu, which has an Input File sub menu. Once the input file is selected, 

further data analysis can be achieved. For the multiple station option, the input file is a file 

containing a list of selected stations. Here, there is an option for making the file list in the sub 

menu of the File menu. 

 

For the Degree Day analysis, the user needs to select an average daily temperature file with the 

extension *.003. The drop-down menu of the Degree Day menu contains menus for Heating 

Degree Day and Cooling Degree Day computations. Clicking the appropriate sub menu 

completes the analysis giving a message about where the output file is saved.   

 

The third menu is the Data Preparation, which has 4 drop-down sub menus that include 

Extract Data Series, Basic Statistic Calculation: used for extreme value series; Daily Data 

Basic Statistics: used for basic statistic computations of the daily data; and Data Validation.  

Extract Data Series has 2 sub menus for the extraction of an annual maximum value (Extreme 

High), and an annual minimum value (Extreme Low). Data Validation has 6 sub menus - 

Randomness, Auto Correlation Test, Mann-Whitney Shift, Box Plot, Mann-Kendall Trend, 
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and Kruskal-Wallis Test. For these tests the user needs to select an annual maximum or 

minimum series as an input file from the File menu. 

 

For the Frequency Analysis, the user first needs to generate the annual maximum or minimum 

series.  The annual maximum or minimum series can be generated by selecting any daily data 

series file as an input file.  Following this, the user must proceed by switching to the Data 

Preparation main menu, then selecting the Extract Data Series, and finally selecting and 

clicking the Extreme High sub menu for the maximum, or Extreme Low sub menu for the 

minimum series.  Once the series computation is complete, the program informs the user of the 

destination of the files computed by a message on the screen.  Now the user needs to select that 

maximum or minimum series as an input file for the Frequency Analysis.  For the High Value 

Frequency Analysis, one must select a maximum data series; while for a Low Value 

Frequency Analysis, one must select a minimum data series.   

 

The High Value Frequency Analysis main menu has 4 sub menus which include: Event of 

Specified Return Period, Return Period of Specified Event, Kolmogorov-Smirnov Test and 

Probability Plot Correlation Coefficient Test.  By selecting the High Value Frequency 

Analysis from the main menu, and choosing one of those sub menus mentioned above, it brings 

the user to an option form in a drop-down list box.  This list box provides 3 options for frequency 

analysis methods - Normal, Gumbel, and Pearson Type 3 Distributions.  Selecting any of the 

available option completes the analysis.  The result of the analysis is written to the screen on the 

screen, and is also saved on a disk.  A message box appears informing the user that the file has 

been saved. 

 

The Low Value Frequency Analysis menu has two sub menus – Left Unbounded and Left 

Bounded by Zero. The Left Unbounded has the sub menus that are identical to the High Value 

Frequency Analysis: Event of Specified Return Period, Return Period of Specified Event, 

Kolmogorov-Smirnov Test, and Probability Plot Correlation Coefficient Test.  By selecting 

any of the sub menus it brings the user to a form, from where one needs to select a frequency 

distribution method in a drop-down list box.  As mentioned previously, 3 methods are available.  

Selecting any of the available options completes the analysis. The result of the analysis comes up 

on the screen, and is also saved on a disk.  A message box appears informing the user that the file 

has been saved. 
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The Left Bounded by Zero sub menu has the same sub menus as that of the Left Unbounded, 

but with 3 additional distributions listed in the drop-down list box.  These include Weibull, Log-

Normal, and Log-Pearson Type 3 Distributions.  

 

For Wind Chill, Heat Index, Heat Wave and Relative Humidity Analysis, one must select the 

appropriate option, and then click the Proceed On Button.  From the Atmospheric Climate 

option, one must choose an appropriate selection.  Depending on the selection made, a screen 

will then appear with the results. 

 

The last menu is the Help menu, which explains each of the menus, sub menus, methods, 

procedures of analysis, data formats, and the sequences of analytical processes.  The Help menu 

can be invoked anytime by pressing the F1 key.  Currently the Help menu items are still at the 

development stages. 

 

3. LOADING THE DATA FILE 

 
The input file is selected by choosing the Input File sub menu from the File menu.  The Input 

File Selection Screen will then appear as shown in Figure 6. 

 

4. CALCULATION PROCEDURE 

 
Clicking on the Start  button in the lower left hand corner of the desktop brings up a menu list.  

A menu list will then appear.  Click on the Programs icon.  From the Programs menu, select 

the STECA sub menu.  Then proceed by clicking the Steca sub menu.  The option screen will 

then appear.  Make the selection of an analysis option and a station option that one wishes to use.  

For a single station option the following analyses can be conducted. 
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Figure 6. File Input Screen 

Single Station Analysis: 
Degree Day 

The analysis begins with the selection of an input file.  The input file is reached by selecting the 

Input File sub menu from the File menu.  The Input File Selection Screen will then appear as 

previously shown in Figure 6.  The Daily Average Temperature File with the extension 003 is 

to be selected.  To load the data file, either double click on the file, or select and click the File 

button.  A screen showing the name of the selected file will then appear.  If the selected file is the 

correct one, press the Yes option to select it.  Click the OK button to proceed with the 

computation. 
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Atmospheric Climate: 
Heat Index 

Begin with the selection of an input file.  The input file is selected by choosing by selecting the 

Input File sub menu from the File menu.  The Input File Selection Screen will then appear as 

previously shown in Figure 6.  The Hourly Atmospheric Temperature (i.e., the dry bulb 

temperature) File with the extension 078 is to be selected.  To load the file, either double click on 

the file, or select and click the File button.  A screen showing the name of the selected file will 

then appear.  If the selected file is the correct one, press the Yes option to select it.  Click the OK 

button to proceed with the computation.  The result of the analysis will then be printed on the 

screen, and a saved to a disk as text file.  A message box appears to indicate the destination of 

the text file. 

 

Heat Wave 

Begin with the selection of an input file.  The input file is selected by choosing the Input File 

sub menu from the File menu.  The Input File Selection Screen will then appear as previously 

shown in Figure 6.  The Daily Maximum Temperature File with the extension 001 is to be 

selected.  To load the file, either double click on the file, or select and click the File button.  A 

screen showing the name of the selected file will then appear.  If the selected file is the correct 

one, press the Yes option to select it.  Click the OK button to proceed with the computation.  

Now, one must go to the Atmospheric Climate menu.  From the drop-down sub menu, select 

and click the Heat Wave sub menu.  The result of the analysis will then be printed on the screen, 

and saved to a disk as a text file.  A message box appears to indicate the destination of the text 

file. 

Cold Wave 

Begin with the selection of an input file.  The input file is selected by choosing the  Input File 

sub menu from the File menu.  The Input File Selection Screen will then appear as previously 

shown in Figure 6.  The Daily Maximum Temperature File with the extension 001 is to be 

selected. To load the file, either double click on the file, or select and click the File button. A 

screen showing the name of the selected file will then appear.  If the selected file is correct, then 

the Yes option is to be selected.  Click the OK button to proceed with the computation.  Now, 

one must go to the Atmospheric Climate menu.  From the drop-down sub menu, select and 

click the Cold Wave sub menu.  The result of the analysis will then be printed on the screen, and 
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a text file will also be saved on a disk.  A message box appears to indicate the destination of the 

text file. 

 
Wind Chill 

Begin with the selection of an input file.  The input file is selected by choosing the Input File 

sub menu from the File menu.  The Input File Selection Screen will then appear as previously 

shown in Figure 6.  The Hourly Atmospheric Temperature (i.e., the dry bulb temperature) File 

with the extension 078 is to be selected.  To load the file, either double click on the file, or select 

and click the File button.  A screen showing the name of the selected file will then appear.  If the 

selected file is correct, then the Yes option is to be selected.  Click the OK button to proceed 

with the computation.  The result of the analysis will then be printed on the screen, and a text file 

will also be saved on a disk.  A message box appears to indicate the destination of the text file. 

 
Relative Humidity 

Clicking on this submenu will bring up a data input screen. Enter the input data in the 

appropriate text boxes and click the Calculate RH button. This action will bring up the results 

on the screen. 

 

Extreme Value Analysis 

The Extreme Value Analysis is done through the annual maximum or annual minimum data 

series.  The extreme value series is extracted from the daily data file. 

 

Extraction of Extreme High Value Series 

From the File menu, select and click the Input File sub menu.  From the  File Selection select 

the appropriate daily data file.  Proceed through the screen prompts. From the Data Preparation 

main menu, select the Extract Data Series sub menu. From this submenu select Extreme High.  

By clicking the Extreme High the annual maximum series will be extracted and will then be 

written to a disk as a text file.  A message box appears to indicate the destination of the text file. 

 

Extraction of Extreme Low Value Series 

From the File menu, go to the Select Input File sub menu. Then from the selection screen, select 

the appropriate daily data file. Proceed through the screen prompts.  From the Data Preparation 

main menu, select the Extract Data Series sub menu. From this submenu select the Extreme 
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Low.  The annual minimum series will be extracted and will then be written to a disk in a text 

file.  A message box appears to indicate the destination of the text file. 

 

Data Validation 

Since the Frequency Analysis is done with the annual maximum or minimum series, the data 

series must be validated first, and it must follow certain assumptions. The following statistical 

tests are performed for Data Validation of the annual maximum or minimum series.  

 

Randomness 

Select an annual maximum or minimum series data file as an input file.  From the Data 

Preparation main menu, select the Data Validation sub menu.  From the drop-down sub menu, 

select and click the Randomness icon.  The Randomness computation screen will then appear.  

Click on the Test Randomness button.  The results of the Randomness test are written to the 

screen and to a disk in a text file “VldFrqOut.” 

 

Auto Correlation Test or Serial Correlation 

Select an annual maximum or minimum series data file as an input file. From the Data 

Preparation main menu, select the Data Validation sub menu.  From the drop-down sub menu, 

select and click the Auto Correlation.  The Serial Correlation computation screen appears.  

Click on the Run button.  The results of the Auto Correlation test are written to the screen, and 

to a disk in a text file “VldFrqOut.” 

 

Mann-Whitney Shift 

Select an annual maximum or minimum series data file as an input file. From the Data 

Preparation main menu, select the Data Validation sub menu.  From the drop-down sub menu, 

select Mann-Whitney Shift.  The Mann-Whitney Shift computation screen appears.  Click on 

the Run button.  The results of the Mann-Whitney Shift test are written to the screen and to a 

disk in a text file “VldFrqOut.” 

 

Box Plot 

Select an annual maximum or minimum series data file as an input file. From the Data 

Preparation main menu, select the Data Validation sub menu.  From the drop-down sub menu, 
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select Box Plot.  The Box Plot computation screen comes up.  Click the Run button.  The results 

of the Box Plot test are written to the screen and to a disk in a text file, “VldFrqOut.” 

 

Mann-Kendall Trend 

Select an annual maximum or minimum series data file as an input file. From the Data 

Preparation main menu, select the Data Validation sub menu.  From the drop-down sub menu, 

select and click the Mann-Kendall Trend icon.  The Mann-Kendall Trend computation screen 

appears.  Click the Run button.  The results of the Mann-Kendall Trend test are written to the 

screen and to a disk in a text file “VldFrqOut.” 

 

Kruskal-Wallis Test 

Select an annual maximum or minimum series data file as an input file. From the Data 

Preparation main menu, select the Data Validation sub menu.  From the drop-down sub menu, 

select the Kruskal-Wallis icon.  The Kruskal-Wallis Test computation screen comes up.  Click 

the Run button.  The results of the Kruskal-Wallis Test are written to the screen and to a disk in 

a text “VldFrqOut.” 

 

Basic Statistics Computation 

Basic Statistics Computations are done for the daily data series and the annual maximum or 

minimum series. 

 

Annual Extreme Value Basic Statistics 

Select an annual maximum or minimum series data file as an input file. From the Data 

Preparation main menu select the Annual Extreme Value Basic Statistics sub menu. The 

Basic Statistics computation screen appears.  Click on the Calculate Basic Statistics button.  

The results of the Basic Statistics computations are written to the screen and to a disk in a text 

file “VldFrqOut.” 

 

Daily Data Basic Statistics 

Select a daily data series file as an input file.  From the Data Preparation main menu select the 

Daily Data Basic Statistic sub menu and then select and click the Calculate Dly Data Basic 

Stat sub menu.  The Basic Statistics of Daily Data computation screen comes up.  Click on the 
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Calculate Basic Statistic button.  The results of the Basic Statistics computation are printed to 

the screen  and to a text file provided by the user. 

 

Student’s t-Test 

From the Data Preparation main menu, select the Daily Data Basic Statistic sub menu, and 

then select and click the Student’s t-Test sub menu.  The Student’s t-Test screen appears.  

Enter the input data in the text boxes provided, and then click the Perform Student’s t-Test 

button.  The result of computation will then be printed to the screen. 

 

Percentile 

From the Data Preparation main menu select the Percentiles sub menu.  The Percentiles of the 

daily data screen appears.  Click the Calculate Percentiles button. An Input Box pops up.  

Enter the desired season and click OK.  Another Input Box pops up. Enter the desired percentile 

value in decimal form (e.g., 0.85 for 85%) and click OK.  The result of computation will then be 

printed to  the screen. 

 

Extreme High Value Frequency Analysis 

From the File menu, select and click the Input File sub menu.  From the Input File Selection 

Screen select an annual maximum series file extracted earlier. The file name must end with 

‘Max’ before the period (.).  For example, 1012040Max.001 is the annual maximum series of the 

daily maximum temperature.  From the High Value FreqAnalysis main menu select the 

appropriate sub menu.  This sub menu presents 4 choices: Kolmogorov-Smirnov Test, 

Probability Plot Correlation Test, Event of Specified Return Period, and Return Period of 

Specified Event.  Clicking on any of these choices, it will bring the user to the next screen.  On 

this screen, the user will need to choose a method of Frequency Distribution Analysis that is 

available from the drop-down list box. Choosing any of the methods and clicking on the Proceed 

On button will calculate the results and print them to the screen.   

 

Extreme Low Value Frequency Analysis 

The same methodology used for applies to the high value frequency applies to the Low Value 

Frequency Analysis. The only difference is that from the main menu selecting Low Value 

Frequency Analysis presents two submenu choices, Left Unbounded and Left Bounded by 

Zero.  Both of these sub menus present four more sub menu choices: Kolmogorov-Smirnov 
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Test, Probability Plot Correlation Test, Event of Specified Return Period, and Return 

Period of Specified Event.  The input file will be an annual minimum series marked by ‘Min’ at 

the end of the file name, e.g. 1012040Min.001.  

 

Multiple Station Analysis 

For the Multiple Station option, the input file is a file containing a list of selected stations.  

There is an option for selecting the file list in the appropriate submenu of the File menu. 

 

Select Input File List 

When multiple station option is selected the multiple station analysis main menu appears. From 

File menu select the Select Input File List submenu, and the File Input screen appears. Open the 

appropriate folder and select the desired file type in the file type list box. Select the desired files. 

To select multiple files hold down the Ctrl key while clicking on them. Once the selection is 

completed, click the Select File button. A screen for entering the name of the list comes up. Type 

in an appropriate name and follow the on-screen instructions. 

 

Select Input File 

Once the list is completed, select it as an input file from the appropriate submenu of the File 

menu. Proceed with the desired analysis as before.  

 

5. SAVING THE OUTPUT 

 
The output of the analysis is printed to the screen and written to a text file as well. A message 

appears to indicate the destination of the text file. 
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